Advanced Woo Search Vulnerability – Reflected Cross-Site Scripting – CVE-2024-0251 | WordPress Plugin Vulnerability Report

Plugin Name: Advanced Woo Search

Key Information:

  • Software Type: Plugin
  • Software Slug: advanced-woo-search
  • Software Status: Active
  • Software Author: Mihail Barinov
  • Software Downloads: 3,318,679
  • Active Installs: 70,000
  • Last Updated: January 12, 2024
  • Patched Versions: 2.97
  • Affected Versions: <= 2.96

Vulnerability Details:

  • Name: Advanced Woo Search <= 2.96
  • Title: Reflected Cross-Site Scripting
  • Type: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
  • CVE: CVE-2024-0251
  • CVSS Score: 6.1
  • Publicly Published: January 12, 2024
  • Researcher: Artem Guzhva (hexcat)
  • Description: The Advanced Woo Search plugin is vulnerable to Reflected Cross-Site Scripting (XSS) in versions up to 2.96. This vulnerability arises from inadequate input sanitization and output escaping in the search parameter. Unauthenticated attackers can exploit this to inject web scripts on pages, especially when Dynamic Content for Elementor plugin is also installed.


The Advanced Woo Search plugin for WordPress, integral for enhancing WooCommerce search capabilities, has been identified with a Reflected XSS vulnerability in versions up to 2.96, cataloged as CVE-2024-0251. This vulnerability can enable unauthenticated attackers to inject malicious scripts through user interactions, such as clicking a link. The issue has been addressed in the newer version 2.97, providing a vital security update.

Detailed Overview:

This vulnerability poses a substantial security threat, as Reflected XSS attacks allow attackers to inject harmful scripts into web pages. These scripts execute when a user interacts with a compromised element, such as a search query. Particularly concerning for sites also utilizing the Dynamic Content for Elementor plugin, this vulnerability can lead to data breaches, session hijacking, and manipulation of site content.

Advice for Users:

  • Immediate Action: Update the plugin to version 2.97 immediately.
  • Check for Signs of Vulnerability: Regularly inspect your website for unusual script executions or unexpected content changes.
  • Alternate Plugins: Consider exploring alternative search plugins as a precaution.
  • Stay Updated: Consistently update your WordPress plugins to protect against vulnerabilities.


The prompt resolution of the Reflected XSS vulnerability in Advanced Woo Search, marked as CVE-2024-0251, emphasizes the critical importance of keeping software up-to-date for web security. WordPress website owners, particularly those utilizing e-commerce functionalities, should urgently upgrade to version 2.97. This incident serves as a crucial reminder for ongoing vigilance in cybersecurity practices to secure digital platforms.



In the ever-evolving landscape of cybersecurity, the discovery of a significant vulnerability in the widely used "Advanced Woo Search" plugin for WordPress highlights the critical importance of regular software updates. Tagged as CVE-2024-0251, this Reflected Cross-Site Scripting (XSS) vulnerability poses a serious threat, particularly for e-commerce websites using WooCommerce. This vulnerability underscores the need for website owners, especially small businesses with limited IT resources, to stay vigilant and proactive in safeguarding their online presence.

Risks/Potential Impacts:

This Reflected XSS vulnerability could allow attackers to inject malicious scripts into web pages, compromising site integrity and user data security. The scripts execute when users interact with a compromised element, such as a search query, potentially leading to data breaches, session hijacking, and manipulation of site content.

Previous Vulnerabilities:

There have been 3 previous vulnerabilities identified in this plugin since May 2, 2019.


The timely patching of CVE-2024-0251 in the Advanced Woo Search plugin is a testament to the importance of keeping software updated for web security. Small business owners managing WordPress sites, especially those utilizing e-commerce functionalities, are advised to urgently upgrade to the patched version. This incident serves as a critical reminder of the ongoing need for vigilance in cybersecurity practices, highlighting the essential role of regular monitoring and updating of software to protect digital assets and maintain user trust.

Staying Secure

Staying on top of WordPress security can feel overwhelming for small business owners without dedicated IT staff. At Your WP Guy, we exist to shoulder that burden for you. Our WordPress experts can fully audit, secure, maintain and support your site - so you can focus on growing your business with peace of mind.

Don't tackle security risks alone. Let us help you assess any impact from this vulnerability, update your plugins, and implement ongoing maintenance to avoid future threats. We treat your website like it's our own - because we know how critical it is for reaching your customers.

Get in touch for a free consultation today on making WordPress security stress-free. Call 678-995-5169 or book a call here. Our knowledgeable team is ready to help you safeguard your online presence.

Advanced Woo Search Vulnerability – Reflected Cross-Site Scripting – CVE-2024-0251 | WordPress Plugin Vulnerability Report FAQs

Leave a Comment