SEO Plugin by Squirrly SEO Vulnerability- Authenticated (Administrator+) Stored Cross-Site Scripting – CVE-2024-0597 |WordPress Plugin Vulnerability Report

Plugin Name: SEO Plugin by Squirrly SEO

Key Information:

  • Software Type: Plugin
  • Software Slug: squirrly-seo
  • Software Status: Active
  • Software Author: cifi
  • Software Downloads: 4,689,778
  • Active Installs: 200,000
  • Last Updated: February 2, 2024
  • Patched Versions: 12.3.16
  • Affected Versions: <= 12.3.15

Vulnerability Details:

  • Name: SEO Plugin by Squirrly SEO <= 12.3.15
  • Title: Authenticated (Administrator+) Stored Cross-Site Scripting via plugin settings
  • Type: CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:L/I:L/A:N
  • CVE: CVE-2024-0597
  • CVSS Score: 4.4
  • Publicly Published: January 29, 2024
  • Researcher: Akbar Kustirama
  • Description: The SEO Plugin by Squirrly SEO for WordPress is vulnerable to Stored Cross-Site Scripting (XSS) through its admin settings in all versions up to and including 12.3.15. This vulnerability arises due to insufficient input sanitization and output escaping, enabling authenticated attackers with administrator-level permissions to inject arbitrary web scripts into pages. These scripts execute whenever a user accesses an injected page, posing a risk primarily to multi-site installations and sites where the unfiltered_html capability is restricted.


The SEO Plugin by Squirrly SEO has been identified to contain a vulnerability in versions up to and including 12.3.15, allowing attackers with administrator-level access to perform Stored Cross-Site Scripting (XSS) attacks via the plugin's settings. This security flaw has been addressed in the patched version 12.3.16.

Detailed Overview:

This vulnerability, identified by security researcher Akbar Kustirama, specifically targets the plugin's administrative settings, where insufficient safeguards against malicious input allow high-level users to embed harmful scripts. These scripts can then be executed unwittingly by other users, leading to potential security breaches. The threat is particularly acute in environments with stringent permissions, such as multi-site WordPress installations or when the unfiltered_html capability is disabled, highlighting the nuanced nature of this vulnerability and the importance of robust security practices in plugin development.

Advice for Users:

To mitigate the risks associated with this vulnerability, users are urged to update the SEO Plugin by Squirrly SEO to the latest patched version, 12.3.16, without delay. Additionally, administrators should review their site for any unusual or unauthorized changes, a common indicator of exploitation. In situations where immediate updating is not feasible, consider temporarily deactivating the plugin or exploring alternative SEO plugins that offer comparable functionality but are not affected by this vulnerability. Maintaining the currency of all installed plugins is a cornerstone of a secure WordPress environment.


The prompt resolution of this vulnerability by the Squirrly SEO team through the release of a patched version underscores the criticality of continuous vigilance and timely updates in the ecosystem of WordPress plugins. Users, especially those managing multi-site installations or with restricted HTML capabilities, should ensure their installations are updated to version 12.3.16 or later to safeguard against potential exploits of this nature.


In today's digital age, the security of your online presence is paramount, especially for small business owners who rely heavily on their websites. The recent identification of a vulnerability in the SEO Plugin by Squirrly SEO, known as CVE-2024-0597, serves as a stark reminder of the continuous threat that outdated software poses to website integrity and user safety. This vulnerability, which affects versions up to and including 12.3.15, highlights the necessity of regular updates and diligent website management to mitigate potential risks.

About the Plugin:

The SEO Plugin by Squirrly SEO is a popular WordPress tool designed to enhance website search engine optimization. Developed by cifi, the plugin boasts over 4.6 million downloads and 200,000 active installations. Its widespread use underscores the significant impact that vulnerabilities within such plugins can have on the broader WordPress community.

Vulnerability Details:

CVE-2024-0597 exposes websites to Authenticated Stored Cross-Site Scripting (XSS) attacks via the plugin's administrative settings, due to insufficient input sanitization and output escaping. This flaw allows attackers with administrator-level access to inject harmful scripts into web pages, which are then executed by users accessing these pages. The vulnerability is particularly concerning for multi-site installations or sites with restricted unfiltered_html capabilities, as it can lead to unauthorized access and data breaches.

Risks and Potential Impacts:

The primary risk of this vulnerability lies in its potential to compromise website security and user data integrity. Attackers could exploit this flaw to gain unauthorized control over websites, steal sensitive information, or distribute malware, posing significant reputational and financial risks to website owners.

Remediation and Advice for Users:

To address this vulnerability, users are urged to update the SEO Plugin by Squirrly SEO to version 12.3.16, which contains the necessary patches. Website administrators should also conduct thorough reviews of their sites for any signs of compromise and consider alternative SEO plugins if immediate updating is not feasible. Regularly updating all WordPress components is crucial in maintaining a secure online environment.

Previous Vulnerabilities:

This is not the first time vulnerabilities have been reported in the SEO Plugin by Squirrly SEO, with six previous instances noted since July 11, 2016. This pattern underscores the importance of continuous monitoring and updating of all software components to protect against evolving threats.


For small business owners, the challenge of staying on top of security vulnerabilities can seem daunting amidst the myriad responsibilities of running a business. However, the potential consequences of neglecting website security are far too significant to ignore. Leveraging automated update features, employing security plugins, and considering professional maintenance services can alleviate some of the burdens and ensure that your WordPress site remains secure and trustworthy. Remember, in the realm of cybersecurity, prevention is always better than cure. Regularly updating your website's plugins and themes is not just a matter of maintaining functionality—it's a critical component of safeguarding your business in the digital world.

Staying Secure

Staying on top of WordPress security can feel overwhelming for small business owners without dedicated IT staff. At Your WP Guy, we exist to shoulder that burden for you. Our WordPress experts can fully audit, secure, maintain and support your site - so you can focus on growing your business with peace of mind.

Don't tackle security risks alone. Let us help you assess any impact from this vulnerability, update your plugins, and implement ongoing maintenance to avoid future threats. We treat your website like it's our own - because we know how critical it is for reaching your customers.

Get in touch for a free consultation today on making WordPress security stress-free. Call 678-995-5169 or book a call here. Our knowledgeable team is ready to help you safeguard your online presence.

SEO Plugin by Squirrly SEO Vulnerability- Authenticated (Administrator+) Stored Cross-Site Scripting – CVE-2024-0597 |WordPress Plugin Vulnerability Report FAQs

Leave a Comment