Orbit Fox by ThemeIsle Vulnerability- Authenticated (Contributor+) Stored Cross-Site Scripting – CVE-2024-1323 | WordPress Plugin Vulnerability Report

Plugin Name: Orbit Fox by ThemeIsle

Key Information:

  • Software Type: Plugin
  • Software Slug: themeisle-companion
  • Software Status: Active
  • Software Author: themeisle
  • Software Downloads: 11,350,926
  • Active Installs: 200,000
  • Last Updated: February 27, 2024
  • Patched Versions: 2.10.32
  • Affected Versions: <= 2.10.31

Vulnerability Details:

  • Name: Orbit Fox by ThemeIsle <= 2.10.30
  • Title: Authenticated (Contributor+) Stored Cross-Site Scripting
  • Type: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
  • CVE: CVE-2024-1323
  • CVSS Score: 6.4
  • Publicly Published: February 26, 2024
  • Researcher: Webbernaut
  • Description: The Orbit Fox by ThemeIsle plugin for WordPress is vulnerable to Stored Cross-Site Scripting (XSS) through its Post Type Grid Widget Title. This vulnerability arises in versions up to and including 2.10.30 due to the lack of proper input sanitization and output escaping for user-supplied attributes. Authenticated users with contributor-level permissions or higher can exploit this flaw to inject arbitrary web scripts into pages, which are executed when other users access the compromised pages.


Orbit Fox by ThemeIsle, a popular WordPress plugin designed to enhance website functionality with widgets and modules, has been found to contain a critical security vulnerability. Identified in versions up to 2.10.31, this flaw allows for stored XSS attacks via manipulated widget titles, posing a significant risk to website integrity and user security. The developers have addressed this issue in the latest patch, version 2.10.32.

Detailed Overview

The vulnerability, discovered by security researcher Webbernaut, underscores the importance of stringent input validation and output encoding in web applications. Without adequate sanitization measures, attackers can embed harmful scripts into widget titles, leading to potential unauthorized access, data leakage, or other malicious activities. The prompt release of version 2.10.32 by ThemeIsle mitigates this vulnerability, enhancing the plugin's security posture.

Advice for Users

  • Immediate Action: It is crucial for users of the Orbit Fox plugin to update to version 2.10.32 immediately to safeguard against this vulnerability.
  • Check for Signs of Vulnerability: Website administrators should inspect their site for unexpected script executions, especially in areas utilizing the affected widget, and review user roles to ensure only trusted users have elevated permissions.
  • Alternate Plugins: While the patched version is now secure, users may explore other reputable plugins offering similar functionality as a precautionary measure.
  • Stay Updated: Maintaining the latest versions of all WordPress components, including plugins, themes, and the core, is vital for ensuring the security and functionality of your site.


The rapid identification and resolution of CVE-2024-1323 within the Orbit Fox plugin highlight the ongoing challenges and importance of cybersecurity vigilance in the WordPress ecosystem. For small business owners and website administrators, this incident serves as a critical reminder of the necessity for regular updates and proactive security measures. By staying informed about potential vulnerabilities and implementing best practices for site maintenance, WordPress users can significantly reduce the risk of security breaches and ensure a safe online environment for their users.


In the rapidly evolving digital landscape, ensuring the security of online platforms is paramount, especially for WordPress site owners who utilize various plugins to enhance functionality and user experience. A recent security vulnerability identified in the popular WordPress plugin, Orbit Fox by ThemeIsle, serves as a crucial reminder of the ongoing need for vigilance in the cybersecurity realm. This plugin, renowned for its versatility in adding widgets and modules to sites, was found to have a significant security loophole in versions up to 2.10.31, cataloged as CVE-2024-1323.

Plugin Overview

Orbit Fox by ThemeIsle extends WordPress sites by adding various widgets, social media elements, and enhanced features. With over 200,000 active installations and a wide user base, its security and functionality are crucial for many.

Vulnerability Details

The vulnerability, specifically targeting the Post Type Grid Widget Title, arises from insufficient input sanitization and output escaping, allowing authenticated users with at least contributor-level permissions to inject malicious scripts into web pages. These scripts can execute upon page access by any user, compromising site integrity and user security. Recognized as CVE-2024-1323, this flaw was publicly disclosed on February 26, 2024, by researcher Webbernaut, with a CVSS score of 6.4 indicating a substantial risk.

Risks and Impacts

The exploitation of this vulnerability can lead to unauthorized access, data breaches, and potentially full site compromise, undermining the trust between the site and its users. It highlights the critical nature of securing user input fields and the potential ramifications of oversight.


In response to this discovery, ThemeIsle promptly released patch 2.10.32 to address the vulnerability, closing the security gap and restoring the plugin's defenses against XSS attacks. Users are urged to update their installations immediately to safeguard their sites.

Previous Vulnerabilities

This is not the first time vulnerabilities have been discovered within the Orbit Fox plugin, with 9 previous issues reported since November 12, 2018. Each incident reinforces the importance of continuous monitoring and updating of software to protect against emerging threats.


The swift identification and resolution of CVE-2024-1323 within the Orbit Fox plugin underscore the critical importance of maintaining up-to-date software on WordPress sites. For small business owners, this incident highlights the necessity of regular updates and proactive security measures to protect digital assets. Staying informed about potential vulnerabilities, implementing best practices for site maintenance, and conducting regular security audits are indispensable practices for securing online platforms against evolving cyber threats. In the digital age, the security of your WordPress site is not just about protecting your data but also about maintaining the trust and confidence of your users.

Staying Secure

Staying on top of WordPress security can feel overwhelming for small business owners without dedicated IT staff. At Your WP Guy, we exist to shoulder that burden for you. Our WordPress experts can fully audit, secure, maintain and support your site - so you can focus on growing your business with peace of mind.

Don't tackle security risks alone. Let us help you assess any impact from this vulnerability, update your plugins, and implement ongoing maintenance to avoid future threats. We treat your website like it's our own - because we know how critical it is for reaching your customers.

Get in touch for a free consultation today on making WordPress security stress-free. Call 678-995-5169 or book a call here. Our knowledgeable team is ready to help you safeguard your online presence.

Orbit Fox by ThemeIsle Vulnerability- Authenticated (Contributor+) Stored Cross-Site Scripting – CVE-2024-1323 | WordPress Plugin Vulnerability Report FAQs

Leave a Comment