Easy Social Feed Vulnerability – Social Photos Gallery – Post Feed – Like Box – Cross-Site Request Forgery – CVE-2024-1214 | WordPress Plugin Vulnerability Report

Plugin Name: Easy Social Feed – Social Photos Gallery – Post Feed – Like Box

Key Information:

  • Software Type: Plugin
  • Software Slug: easy-facebook-likebox
  • Software Status: Active
  • Software Author: sjaved
  • Software Downloads: 2,976,834
  • Active Installs: 50,000
  • Last Updated: March 14, 2024
  • Patched Versions: 6.5.5
  • Affected Versions: <= 6.5.4

Vulnerability Details:

  • Name: Easy Social Feed <= 6.5.4
  • Title: Cross-Site Request Forgery
  • Type: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
  • CVE: CVE-2024-1214
  • CVSS Score: 4.3
  • Publicly Published: March 12, 2024
  • Researcher: Eldar Zeynalli
  • Description: The Easy Social Feed plugin is compromised by a Cross-Site Request Forgery (CSRF) vulnerability due to inadequate nonce validation in the save_groups_list function. This flaw permits unauthenticated attackers to sever the plugin's connection with Facebook or Instagram pages/groups through a forged request if they can deceive an administrator into taking a specific action, such as clicking a link.


The Easy Social Feed plugin, integral to numerous WordPress sites for displaying social media content, faces a notable security vulnerability in versions up to 6.5.4. Identified as CVE-2024-1214, this Cross-Site Request Forgery vulnerability poses risks to site connectivity with social platforms. Thankfully, this issue has been rectified in the latest update, version 6.5.5, bolstering the plugin's security.

Detailed Overview:

This vulnerability, unearthed by researcher Eldar Zeynalli, highlights the critical necessity of stringent nonce validation in preventing CSRF attacks. Such vulnerabilities could lead to the unintended alteration of plugin settings or disconnection from social media platforms, potentially impacting the website's functionality and user engagement.

Advice for Users:

  • Immediate Action: It is crucial to update the Easy Social Feed plugin to version 6.5.5 without delay to mitigate this vulnerability.
  • Check for Signs of Vulnerability: Administrators should vigilantly monitor their website for any unauthorized changes to the plugin's settings or social media connections, indicating possible exploitation.
  • Alternate Plugins: While the current version addresses this vulnerability, users may evaluate alternative plugins that provide similar functionalities with robust security measures.
  • Stay Updated: Ensuring that all WordPress components are updated regularly is paramount in safeguarding against vulnerabilities and optimizing website performance.


The prompt amendment of CVE-2024-1214 in the Easy Social Feed plugin underlines the enduring imperative for proactive security measures within the WordPress community. For website administrators, especially those managing small businesses with limited technical support, the dedication to routine software updates and adherence to security best practices is fundamental in protecting digital assets against emerging threats.


In a digital environment where cyber threats loom large, the recent discovery of a vulnerability in the "Easy Social Feed – Social Photos Gallery – Post Feed – Like Box" plugin serves as a stark reminder of the importance of diligent website maintenance and security vigilance. This plugin, designed to enhance WordPress sites by integrating social media content seamlessly, was found to have a Cross-Site Request Forgery (CSRF) vulnerability in versions up to and including 6.5.4, cataloged under CVE-2024-1214.

Vulnerability Details:

This vulnerability, discovered by researcher Eldar Zeynalli, highlights a critical flaw in the plugin's 'save_groups_list' function, where insufficient nonce validation could allow unauthenticated attackers to manipulate the plugin's settings. Specifically, attackers could sever the plugin's connection with connected Facebook or Instagram pages/groups by tricking an administrator into clicking a malicious link. This vulnerability was assigned a CVSS score of 4.3, indicating a moderate level of risk.

Risks and Impacts:

The primary risk associated with this vulnerability is the potential exposure and unauthorized manipulation of sensitive information, particularly connections to social media accounts. Such actions could disrupt the seamless display of social media content on affected websites, impacting user engagement and trust.


Users of the Easy Social Feed plugin should immediately upgrade to version 6.5.5, which addresses this vulnerability and restores secure functionality. Website administrators are also advised to review their sites for any unusual changes or unauthorized activities that could indicate exploitation.

Previous Vulnerabilities:

It is noteworthy that this plugin has had 8 previous vulnerabilities since March 4, 2022. This history underscores the need for continuous monitoring and updating of all website components.


The prompt resolution of CVE-2024-1214 in the Easy Social Feed plugin is a critical reminder of the ongoing challenges posed by cybersecurity threats. For small business owners and website administrators, particularly those with limited technical resources, understanding the importance of routine software updates and security best practices is fundamental. Staying informed and proactive in maintaining website security is indispensable for safeguarding digital assets and ensuring the continued trust and safety of users in the complex landscape of web security.

Staying Secure

Staying on top of WordPress security can feel overwhelming for small business owners without dedicated IT staff. At Your WP Guy, we exist to shoulder that burden for you. Our WordPress experts can fully audit, secure, maintain and support your site - so you can focus on growing your business with peace of mind.

Don't tackle security risks alone. Let us help you assess any impact from this vulnerability, update your plugins, and implement ongoing maintenance to avoid future threats. We treat your website like it's our own - because we know how critical it is for reaching your customers.

Get in touch for a free consultation today on making WordPress security stress-free. Call 678-995-5169 or book a call here. Our knowledgeable team is ready to help you safeguard your online presence.

Easy Social Feed Vulnerability – Social Photos Gallery – Post Feed – Like Box – Cross-Site Request Forgery – CVE-2024-1214 | WordPress Plugin Vulnerability Report FAQs

Leave a Comment