Plugin Name: Simple Calendar – Google Calendar Plugin
- Software Type: Plugin
- Software Slug: google-calendar-events
- Software Status: Active
- Software Author: simplecalendar
- Software Downloads: 2,568,146
- Active Installs: 60,000
- Last Updated: October 20, 2023
- Patched Versions: 3.2.5
- Affected Versions: <3.2.5
- Name: Simple Calendar <= 3.2.4 - Cross-Site Request Forgery via duplicate_feed
- Title: Cross-Site Request Forgery
- Type: Cross-Site Request Forgery (CSRF)
- CVSS Score: 4.3 (Medium)
- Publicly Published: October 20, 2023
- Description: The Simple Calendar – Google Calendar Plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to 3.2.5 (exclusive). This is attributed to the missing or incorrect nonce validation on the duplicate_feed function. Consequently, it's possible for unauthenticated attackers to duplicate feeds via a forged request, especially if they manage to deceive a site administrator into performing specific actions, such as clicking on a deceptive link.
The Simple Calendar – Google Calendar Plugin for WordPress has a vulnerability in versions up to and including those before 3.2.5 that makes it susceptible to Cross-Site Request Forgery due to issues with nonce validation in the duplicate_feed function. This vulnerability has been patched in version 3.2.5.
This vulnerability was discovered in the Simple Calendar – Google Calendar Plugin for WordPress. The issue lies within the nonce validation in the duplicate_feed function. Essentially, the plugin does not effectively validate or might entirely lack nonce validation, making the plugin susceptible to CSRF attacks. With this vulnerability, unauthenticated attackers can exploit the situation by duplicating feeds, but this would require tricking a site's administrator into clicking on a malicious link. The vulnerability is of medium severity, with a CVSS score of 4.3.
Advice for Users:
- Immediate Action: Users are strongly urged to update to the patched version 3.2.5 immediately.
- Check for Signs of Vulnerability: Regularly monitor your plugin's activities, and be cautious of unexpected feed duplications or any unusual behavior within the plugin.
- Alternate Plugins: While a patch is available, as a precaution, users might consider other plugins offering similar functionalities.
- Stay Updated: Always make sure that your plugins are updated to the most recent versions to mitigate vulnerabilities.
The swift response from the plugin developers in addressing this vulnerability highlights the significance of prompt updates. To safeguard their WordPress installations, users are advised to ensure they are operating on version 3.2.5 or subsequent versions.
Keeping your WordPress site and its plugins up-to-date is crucial for maintaining a secure online presence. Unfortunately, an important calendar plugin for WordPress contains a vulnerability in certain versions that could put your site at risk.
The Simple Calendar – Google Calendar Plugin, which has over 2.5 million downloads and 60,000 active installs, is susceptible to Cross-Site Request Forgery (CSRF) in versions prior to 3.2.5. This issue allows attackers to duplicate calendar feeds by tricking administrators into clicking malicious links. With a CVSS severity score of 4.3 out of 10, it is considered a medium risk vulnerability.
If you are using the Simple Calendar plugin on your WordPress site, it is highly recommended that you update to version 3.2.5 immediately. This will patch the CSRF vulnerability and secure your calendar feeds.
Here are more details on the vulnerability:
- The issue lies in the nonce validation in the duplicate_feed function of the plugin. Essentially, the plugin does not properly validate or lacks nonce validation entirely, leaving it open to CSRF attacks.
- With this vulnerability, an unauthenticated attacker could exploit it by duplicating feeds if they trick an administrator into clicking on a malicious link.
- The vulnerability has been given a CVSS score of 4.3 out of 10, which means it is medium severity.
- The vulnerability affects all versions of the plugin up to and including 3.2.4. Version 3.2.5 contains the patch.
- If successfully exploited, the impact could allow attackers to duplicate calendar feeds, create spam calendar events, or other unintended consequences.
To mitigate this vulnerability:
- Upgrade to version 3.2.5 of the Simple Calendar plugin immediately. This contains the fix.
- Monitor your calendar feeds for any unusual duplications or behavior.
- Consider switching to alternate calendar plugins as a precaution.
- Make sure all your plugins stay updated to the latest versions.
This is the 3rd vulnerability found in the Simple Calendar plugin since October 2014, so staying vigilant about updates is important. As a small business owner, keeping on top of security issues like this may not be top of mind, but is vitally important to the safety and security of your website. Consider automating plugin updates or hiring a web administrator to handle technical site maintenance. The time investment is worth it to protect your online presence.
As a business owner, you don't have time to constantly monitor for WordPress vulnerabilities like this. At Your WP Guy, we become your outsourced IT team to handle security, updates, maintenance and support. Let us fully audit your site and plugins to assess any impact from this issue. We'll update everything to patched versions so you can rest easy knowing your site is locked down.
Focus on your business goals while we focus on your WordPress site's security. Chat with us anytime during business hours, schedule a call or call 678-995-5169 for a free consultation on securing your online presence.