WordPress Plugin Vulnerability Report – Analytify – Cross-Site Request Forgery

Plugin Name: Analytify

Key Information:

  • Software Type: Plugin
  • Software Slug: wp-analytify
  • Software Status: Active
  • Software Author: hiddenpearls
  • Software Downloads: 1,817,063
  • Active Installs: 40,000
  • Last Updated: November 20, 2023
  • Patched Versions: 5.2.0
  • Affected Versions: <= 5.1.0

Vulnerability Details:

  • Name: Analytify Dashboard <= 5.1.0 - Cross-Site Request Forgery
  • Title: Cross-Site Request Forgery
  • Type: Cross-Site Request Forgery (CSRF)
  • CVSS Score: 4.3 (Medium)
  • Publicly Published: November 20, 2023
  • Description: The Analytify – Google Analytics Dashboard For WordPress (GA4 analytics made easy) plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 5.1.0. This is due to missing or incorrect nonce validation on the send_analytics_email function. This makes it possible for unauthenticated attackers to send a feedback email usually sent on uninstall with admin consent via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.


The Analytify plugin for WordPress has a cross-site request forgery (CSRF) vulnerability in versions up to and including 5.1.0 that could allow unauthenticated attackers to trick administrators into taking unwanted actions. This has been patched in version 5.2.0.

Detailed Overview:

The vulnerability is due to improper validation of nonces in the send_analytics_email function of the plugin. This function is used to send feedback emails on uninstall, but normally requires admin consent. However, the lack of proper nonce validation means an attacker could forge requests to this function without consent if they can trick an admin into a simple action like clicking a link. This would allow the sending of unwanted emails from the victim's site.

The vulnerability was publicly disclosed on November 20, 2023. It affects all versions up to and including 5.1.0. Users are encouraged to update to version 5.2.0 or later, which properly validates nonces to prevent CSRF attacks.

Advice for Users:

  1. Immediate Action: Update to Analytify version 5.2.0 or later.
  2. Check for Signs of Vulnerability: Review email logs for any unauthorized emails sent through the plugin.
  3. Alternate Plugins: Consider alternate analytics plugins like Google Analytics Dashboard or MonsterInsights.
  4. Stay Updated: Always keep plugins updated, especially when vulnerabilities are disclosed.


Analytify fixed this vulnerability promptly by patching the nonce validation in version 5.2.0. Users should update as soon as possible to prevent potential CSRF attacks. This incident highlights the ongoing importance of timely security updates.




Detailed Report:

Keeping your WordPress website and its plugins up-to-date is one of the most important things you can do to maintain security. Unfortunately, too many site owners fail to apply timely security updates, leaving their sites exposed to vulnerabilities that can be exploited by attackers. This was highlighted again recently with the disclosure of a cross-site request forgery (CSRF) vulnerability in the popular Analytify plugin.

Analytify is an analytics plugin with over 1.8 million downloads. It integrates Google Analytics into the WordPress dashboard to provide site performance insights. However, versions up to and including 5.1.0 contain a CSRF vulnerability that puts sites at risk.

This vulnerability allows attackers to potentially take unwanted actions by tricking admins into clicking malicious links. Specifically, the vulnerability is due to improper nonce validation in the send_analytics_email function. This could let attackers forge requests to send emails from vulnerable sites without consent if they can trick an admin.

The risks of this vulnerability are mainly around phishing and unauthorized use of the site to send spam. Attackers could exploit it to harvest user emails or spread malware. While no known exploits have been observed yet, it's crucial to patch before this weakness is taken advantage of.

Analytify has addressed this vulnerability in version 5.2.0 by implementing proper nonce validation. All users should update immediately to close the security hole. You can do this manually via the WordPress dashboard or use automated tools like Wordfence to scan and upgrade vulnerable plugins.

Be sure to also review email logs after updating to check for any unauthorized messages that may have been sent before the patch. Consider additional protections like two-factor authentication as well.

This is far from the first vulnerability found in Analytify recently. In the past year, five other security issues have been reported including other CSRF flaws, stored XSS, and information disclosure bugs. This underscores the need to promptly patch vulnerabilities and not let things linger.

Staying on top of WordPress security can feel overwhelming for small business owners without dedicated IT staff. At Your WP Guy, we exist to shoulder that burden for you. Our WordPress experts can fully audit, secure, maintain and support your site - so you can focus on growing your business with peace of mind.

Don't tackle security risks alone. Let us help you assess any impact from this vulnerability, update your plugins, and implement ongoing maintenance to avoid future threats. We treat your website like it's our own - because we know how critical it is for reaching your customers.

Get in touch for a free consultation today on making WordPress security stress-free. Call 678-995-5169 or book a call here. Our knowledgeable team is ready to help you safeguard your online presence.

WordPress Plugin Vulnerability Report – Analytify – Cross-Site Request Forgery FAQs

Leave a Comment