WebSub Vulnerability – Authenticated (Admin+) Stored Cross-Site Scripting – CVE-2024-0688 | WordPress Plugin Vulnerability Report

Plugin Name: WebSub

Key Information:

  • Software Type: Plugin
  • Software Slug: pubsubhubbub
  • Software Status: Active
  • Software Author: joshfraz
  • Software Downloads: 1,744,325
  • Active Installs: 100,000
  • Last Updated: January 24, 2024
  • Patched Versions: 3.2.0
  • Affected Versions: <= 3.1.4

Vulnerability Details:

  • Name: WebSub (FKA. PubSubHubbub) <= 3.1.4 - Authenticated (Admin+) Stored Cross-Site Scripting
  • Title: Authenticated (Admin+) Stored Cross-Site Scripting
  • Type: Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS)
  • CVE: CVE-2024-0688
  • CVSS Score: 4.4 (Medium)
  • Publicly Published: January 24, 2024
  • Researcher: Sh
  • Description: The "WebSub (FKA. PubSubHubbub)" plugin for WordPress is vulnerable to Stored Cross-Site Scripting via plugin settings in all versions up to, and including, 3.1.4 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.


The WebSub plugin for WordPress has a vulnerability in versions up to and including 3.1.4 that allows authenticated administrators to inject malicious scripts that execute when pages are loaded. This vulnerability has been patched in version 3.2.0.

Detailed Overview:

A vulnerability was discovered in the WebSub WordPress plugin that allows authenticated administrators to store malicious scripts in the plugin settings. Due to insufficient sanitization of inputs, these scripts can then execute whenever a vulnerable page is loaded. This exposes sites relying on versions 3.1.4 and below to potential compromise by high privilege users. The issue resides specifically in the handling of input when saving plugin settings. Researchers advise updating to version 3.2.0, which properly sanitizes inputs before saving to prevent script injection. Sites currently running vulnerable versions of WebSub may be compromised without clear traces. Administrators are encouraged to check plugin logs and scripts on any suspect pages.

Advice for Users:

  1. Immediate Action: Update to version 3.2.0 or higher to patch this vulnerability.
  2. Check for Signs of Vulnerability: Review plugin logs and scripts running on critical pages to ensure your site has not already been compromised.
  3. Alternate Plugins: Consider alternative plugins like FeedWordPress or RSS Post Importer to manage feeds while this vulnerability is addressed.
  4. Stay Updated: Ensure any WordPress plugins you rely on are promptly updated to their latest secure versions.


The quick response from WebSub developers to address this vulnerability highlights the need for prompt patching of critical software. Users should ensure they are running version 3.2.0 or higher, while monitoring their sites for any indicators of unauthorized script injection until the update can be applied.




Detailed Report:

Running a small business is demanding enough without worrying about cybersecurity threats. But ignoring your website's vulnerabilities can lead to compromise or site downtime - both disastrous for business operations. Unfortunately, a serious vulnerability was recently revealed in versions of the popular WebSub WordPress plugin, used by over 100,000 sites to manage feeds and subscriptions. Updating this plugin is critical for any affected sites.

About WebSub

The WebSub plugin powers subscription and notification services in WordPress. With over 1.7 million downloads historically, it's a common choice for site owners needing feed management features. The software is actively maintained and updated.

Details of the Vulnerability

Researchers discovered a stored cross-site scripting (XSS) vulnerability affecting WebSub versions 3.1.4 and below. This issue allows a site administrator to inject malicious scripts into pages that then execute for any visiting user. Attackers could leverage this to fully compromise and takeover affected sites. The vulnerability received a mediume severity CVSS rating of 4.4.

Impacts of this Vulnerability

This vulnerability allows for privilege escalation and site takeover without the need for reader or subscriber level access. Attackers must have admin access, but could potentially obtain this via other means and then utilize this injection issue to establish persistency and steal data or spread malware. On its own, this vulnerability represents unacceptable site risk exposure requiring immediate patching.

How to Patch this Vulnerability

All sites using the WebSub plugin should update to version 3.2.0, released January 24, 2024, to resolve this stored XSS issue. You should also conduct a security audit to detect any indicators of exploitation, including unfamiliar admin accounts or script injections. Removing old plugin versions can provide further assurance.

Prior Vulnerabilities

WebSub has faced security issues in the past, including an authenticated SQL injection flaw in mid-2023 affecting over 300,000 sites. The consistent security problems in WebSub underscore the general risks posed by outdated WordPress plugins. Sites relying on this plugin require vigilant patching and audits.

Importance of Staying Updated

The strained time and resources of small business owners make detailed cybersecurity practices impractical. But failing to patch known dangerous plugin flaws like this WebSub vulnerability poses substantial risk of compromise, defacement and more. Where possible, business owners should explore managed website security providers to handle audits, updates and threat monitoring. The threats are real, but so are trusted solutions for reducing website security burdens.

Security vulnerabilities like this one demonstrate the importance of having WordPress experts regularly monitor, maintain and update your site. At Your WP Guy, we offer ongoing management to handle updates, security monitoring, backups, uptime and support so you can stop worrying and get back to growing your business.

Let us fully audit your site to check for any signs of this vulnerability or other issues. We'll immediately update any out-of-date plugins and harden your site's security. Chat with us anytime during business hours, schedule a call or call 678-995-5169 to lock down your online presence.

WebSub Vulnerability – Authenticated (Admin+) Stored Cross-Site Scripting – CVE-2024-0688 | WordPress Plugin Vulnerability Report FAQs

Leave a Comment