SiteOrigin Widgets Bundle Vulnerability – Authenticated (Contributor+) Stored Cross-Site Scripting – CVE-2024-1723 | WordPress Plugin Vulnerability Report

Plugin Name: SiteOrigin Widgets Bundle

Key Information:

  • Software Type: Plugin
  • Software Slug: so-widgets-bundle
  • Software Status: Active
  • Software Author: gpriday
  • Software Downloads: 38,486,908
  • Active Installs: 600,000
  • Last Updated: March 7, 2024
  • Patched Versions: 1.58.8
  • Affected Versions: <= 1.58.7

Vulnerability Details:

  • Name: SiteOrigin Widgets Bundle <= 1.58.7
  • Title: Authenticated (Contributor+) Stored Cross-Site Scripting
  • Type: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
  • CVE: CVE-2024-1723
  • CVSS Score: 6.4
  • Publicly Published: March 4, 2024
  • Researcher: Wesley
  • Description: The SiteOrigin Widgets Bundle plugin for WordPress is vulnerable to Stored Cross-Site Scripting (XSS) in versions up to and including 1.58.7. This vulnerability arises from insufficient input sanitization and output escaping, allowing authenticated attackers with contributor access or higher to inject arbitrary web scripts into pages. These scripts can execute whenever a user accesses an infected page, potentially leading to unauthorized access or manipulation of user data. The affected parameters include but are not limited to $instance['fonts']['title_options']['tag'], $headline_tag, $sub_headline_tag, and $feature['icon'].


The SiteOrigin Widgets Bundle for WordPress has been identified with a Stored Cross-Site Scripting vulnerability in versions up to and including 1.58.7. This critical security issue, which allows authenticated attackers to inject malicious scripts, has been resolved in the patched version 1.58.8.

Detailed Overview:

This vulnerability, discovered by researcher Wesley, poses a significant security threat as it enables attackers with at least contributor-level access to inject harmful scripts into web pages. Such actions can compromise website integrity and user data security, making it imperative for site administrators to address this vulnerability promptly. The potential for misuse underscores the necessity for stringent input validation and output encoding practices in plugin development.

Advice for Users:

  • Immediate Action: Update to the patched version 1.58.8 without delay to mitigate the vulnerability.
  • Check for Signs of Vulnerability: Regularly review website content and user roles to identify any unauthorized changes or additions that could indicate exploitation.
  • Alternate Plugins: Consider exploring alternative plugins that provide similar functionalities, especially if they offer more robust security features or if updates are not feasible immediately.
  • Stay Updated: Continuously monitor and update all WordPress plugins and themes to their latest versions to safeguard against known vulnerabilities.


The rapid response in patching the vulnerability in the SiteOrigin Widgets Bundle illustrates the critical role of timely software updates in maintaining website security. To protect against potential exploits, users must ensure that their WordPress installations, including all plugins and themes, are kept up to date with the latest security patches.


In today's digital ecosystem, the security of your website is not just about protecting your content but safeguarding the trust your users place in you. The recent discovery of a critical vulnerability in the widely-used SiteOrigin Widgets Bundle plugin for WordPress underscores the constant vigilance required to maintain that trust. Known as CVE-2024-1723, this vulnerability exposes websites to potential unauthorized access and manipulation, serving as a stark reminder of the ever-present need to keep digital assets up to date and secure.

The SiteOrigin Widgets Bundle: A Cornerstone of WordPress Customization

The SiteOrigin Widgets Bundle is a popular plugin that enhances WordPress sites with a wide range of widgets, adding flexibility and functionality to site designs. Developed by gpriday, the plugin boasts over 600,000 active installs and more than 38 million downloads. Its role in crafting engaging and dynamic websites makes it a staple in the WordPress community.

Understanding the Vulnerability

CVE-2024-1723 is classified as an Authenticated (Contributor+) Stored Cross-Site Scripting (XSS) vulnerability. It arises from the plugin's failure to adequately sanitize input and escape output, allowing users with contributor-level access or higher to inject malicious scripts into web pages. These scripts can execute whenever the affected page is accessed, leading to potential unauthorized data access and website manipulation. The vulnerability impacts all versions up to and including 1.58.7, with a CVSS score of 6.4, indicating a significant security risk.

Risks and Potential Impacts

The implications of this vulnerability extend beyond mere technical glitches; they threaten the very integrity of the affected websites. Malicious scripts injected through this vulnerability can compromise user data, steal credentials, and even deface or take control of the website. For small businesses, such breaches can result in reputational damage, loss of customer trust, and potential legal ramifications.

Remediation and Proactive Measures

To address this vulnerability, the developers released a patched version of the plugin, 1.58.8. Website owners and administrators must prioritize updating to this latest version to mitigate the risk. Additionally, regularly reviewing website content, user roles, and permissions can help identify and prevent exploitation. For those unable to update immediately, exploring alternative plugins with similar functionality but stronger security measures may be a temporary solution.

Historical Context and the Importance of Vigilance

This is not the first time the SiteOrigin Widgets Bundle has faced security issues; there have been four previous vulnerabilities reported since November 27, 2023. This history highlights the importance of ongoing vigilance and the need for a proactive approach to website security.

The Non-Negotiable Necessity of Digital Vigilance

For small business owners, the digital aspect of operations can often seem like unfamiliar territory, where the demands of staying abreast of security updates and vulnerabilities can feel overwhelming. However, the consequences of neglecting these aspects are far too significant to ignore. Implementing routine checks, staying informed about the latest security threats, and taking immediate action to address vulnerabilities are crucial steps in protecting your digital presence and, by extension, your business's reputation and customer trust.

In conclusion, the discovery of CVE-2024-1723 within the SiteOrigin Widgets Bundle serves as a timely reminder of the intrinsic vulnerabilities within digital tools and the ongoing need for vigilance. For small business owners, the task may seem daunting, but the security of your website is fundamental to maintaining the trust and safety of your users. Embracing a culture of continuous improvement, regular updates, and proactive security measures is not just good practice—it's essential to thriving in the digital age.

Staying Secure

Staying on top of WordPress security can feel overwhelming for small business owners without dedicated IT staff. At Your WP Guy, we exist to shoulder that burden for you. Our WordPress experts can fully audit, secure, maintain and support your site - so you can focus on growing your business with peace of mind.

Don't tackle security risks alone. Let us help you assess any impact from this vulnerability, update your plugins, and implement ongoing maintenance to avoid future threats. We treat your website like it's our own - because we know how critical it is for reaching your customers.

Get in touch for a free consultation today on making WordPress security stress-free. Call 678-995-5169 or book a call here. Our knowledgeable team is ready to help you safeguard your online presence.

SiteOrigin Widgets Bundle Vulnerability – Authenticated (Contributor+) Stored Cross-Site Scripting – CVE-2024-1723 | WordPress Plugin Vulnerability Report FAQs

Leave a Comment