Shariff Wrapper Vulnerability – Authenticated (Admin+) Stored Cross-Site Scripting – CVE-2024-1106 |WordPress Plugin Vulnerability Report

Plugin Name: Shariff Wrapper

Key Information:

  • Software Type: Plugin

  • Software Slug: shariff
  • Software Status: Active
  • Software Author: 3uu
  • Software Downloads: 848,443
  • Active Installs: 50,000
  • Last Updated: February 8, 2024
  • Patched Versions: 4.6.10
  • Affected Versions: <= 4.6.9

Vulnerability Details:

  • Name: Shariff Wrapper <= 4.6.9
  • Title: Authenticated (Admin+) Stored Cross-Site Scripting
  • Type: CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:L/I:L/A:N
  • CVE: CVE-2024-1106
  • CVSS Score: 4.4
  • Publicly Published: February 5, 2024
  • Researcher: Dmitrii Ignatyev - CleanTalk Inc
  • Description: The Shariff Wrapper plugin for WordPress is vulnerable to Stored Cross-Site Scripting (XSS) within the admin settings, affecting all versions up to and including 4.6.9. This vulnerability arises from insufficient input sanitization and output escaping, allowing attackers with administrative privileges to inject malicious scripts. This poses a risk primarily in multi-site installations or in environments where the unfiltered_html capability is restricted.


The Shariff Wrapper plugin, utilized by over 50,000 WordPress sites for enhancing social media sharing features, has been found to contain a Stored Cross-Site Scripting vulnerability in versions up to and including 4.6.9. This security flaw requires administrative level access to exploit and could lead to arbitrary web script injections in admin settings pages. A security update in version 4.6.10 has been released to address this vulnerability.

Detailed Overview:

This vulnerability, discovered by Dmitrii Ignatyev from CleanTalk Inc, highlights the critical importance of robust input validation and output encoding in web applications. The specific risk associated with this vulnerability is the potential for an attacker, who has gained administrative access, to embed harmful scripts into the plugin's settings pages. These scripts could then execute in the context of other users' sessions, leading to possible data leaks or unauthorized actions being performed on their behalf. It's important to note that the risk is elevated in multi-site WordPress installations and environments with stricter content posting permissions.

Advice for Users:

  • Immediate Action: Administrators of WordPress sites using the Shariff Wrapper plugin should immediately update to version 4.6.10, which contains the necessary patches for this vulnerability.
  • Check for Signs of Vulnerability: Site administrators should review their plugin settings and site content for any unexpected or suspicious scripts, especially if administrative access has been broadly granted or if there have been known security breaches.
  • Alternate Plugins: While the immediate update is crucial, users may also consider evaluating alternative social media sharing plugins, particularly those with a strong security track record and frequent updates.
  • Stay Updated: Maintaining the latest versions of all WordPress plugins is vital for security. Regularly check for and apply updates to ensure protection against known vulnerabilities.


The prompt action by the developers of Shariff Wrapper to release a patch for this vulnerability underscores the ongoing challenge of web security and the need for continuous vigilance. Users of the Shariff Wrapper plugin should ensure they have updated to version 4.6.10 or later to secure their sites against this XSS vulnerability. As always, keeping software up to date, practicing the principle of least privilege with administrative access, and staying informed about potential security issues are key strategies in safeguarding WordPress installations.


In today's digital ecosystem, the security of WordPress websites is paramount, yet often underappreciated until a breach occurs. The recent discovery of a vulnerability within the Shariff Wrapper plugin, tagged as CVE-2024-1106, serves as a poignant reminder of the relentless vigilance required to protect our online spaces. This plugin, integral for enhancing social media sharing functionalities on over 50,000 sites, was found to harbor a Stored Cross-Site Scripting (XSS) flaw in versions up to and including 4.6.9. Such vulnerabilities not only highlight the critical need for rigorous development practices but also underscore the potential risks associated with expansive administrative access.

Plugin Overview:

Shariff Wrapper, developed by 3uu, has been a popular choice among WordPress users, facilitating enhanced user engagement through social media buttons. With 848,443 downloads and a substantial active install base, its impact is widespread. The plugin's last update before the discovery of the vulnerability was on February 8, 2024, with the issue being addressed in the subsequent patch, version 4.6.10.

Vulnerability Insights:

CVE-2024-1106 exposes sites to risks where attackers with admin-level privileges could inject harmful scripts into the admin settings, exploiting insufficient input sanitization and output escaping mechanisms. This vulnerability is particularly concerning for multi-site installations or environments with restricted unfiltered_html capabilities, potentially leading to unauthorized actions or data exposure.

Risks and Potential Impacts:

The implications of this vulnerability are far-reaching, with the potential for data breaches, compromised site integrity, and erosion of user trust. The requirement for administrative access to exploit this flaw offers some mitigation, but it remains a stark reminder of the potential damage that can arise from even a single point of vulnerability.

Remediation Steps:

To safeguard against this threat, it's imperative that users of the Shariff Wrapper plugin immediately update to the patched version 4.6.10. Additionally, administrators should conduct a thorough review of their site's plugin settings and content for any anomalies, particularly if administrative privileges have been extensively distributed or if a breach is suspected.

Previous Vulnerabilities:

While CVE-2024-1106 is the current focus, it's important to acknowledge that this isn't the first vulnerability identified in the Shariff Wrapper plugin. Each previous incident serves as a learning opportunity, emphasizing the importance of ongoing vigilance and the need for regular security assessments.


The swift response by the Shariff Wrapper developers in patching this vulnerability underscores a crucial aspect of digital stewardship: the imperative of timely updates. For small business owners juggling myriad responsibilities, the task of staying abreast of every security update can seem daunting. However, the consequences of neglecting this aspect of website maintenance can be dire. Employing automated update solutions, utilizing managed WordPress hosting services, and engaging cybersecurity professionals for periodic audits can significantly mitigate these risks, ensuring that your digital presence remains secure and resilient against evolving threats.

In the digital age, the security of your website is a cornerstone of your business's integrity and trustworthiness. As such, staying informed and proactive in addressing vulnerabilities like CVE-2024-1106 is not just a technical necessity but a fundamental business practice.

Staying Secure

Staying on top of WordPress security can feel overwhelming for small business owners without dedicated IT staff. At Your WP Guy, we exist to shoulder that burden for you. Our WordPress experts can fully audit, secure, maintain and support your site - so you can focus on growing your business with peace of mind.

Don't tackle security risks alone. Let us help you assess any impact from this vulnerability, update your plugins, and implement ongoing maintenance to avoid future threats. We treat your website like it's our own - because we know how critical it is for reaching your customers.

Get in touch for a free consultation today on making WordPress security stress-free. Call 678-995-5169 or book a call here. Our knowledgeable team is ready to help you safeguard your online presence.

Shariff Wrapper Vulnerability – Authenticated (Admin+) Stored Cross-Site Scripting – CVE-2024-1106 |WordPress Plugin Vulnerability Report FAQs

Leave a Comment