Elementor Addon Elements Vulnerability – Authenticated (Contributor+) Stored Cross-Site Scripting – CVE-2024-0834 |WordPress Plugin Vulnerability Report

Plugin Name: Elementor Addon Elements

Key Information:

  • Software Type: Plugin
  • Software Slug: addon-elements-for-elementor-page-builder
  • Software Status: Active
  • Software Author: webtechstreet
  • Software Downloads: 2,364,972
  • Active Installs: 100,000
  • Last Updated: February 8, 2024
  • Patched Versions: 1.12.12
  • Affected Versions: 1.12.11 - 1.12.11

Vulnerability Details:

  • Name: Elementor Addon Elements <= 1.12.11
  • Title: Authenticated (Contributor+) Stored Cross-Site Scripting
  • Type: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
  • CVE: CVE-2024-0834
  • CVSS Score: 6.4
  • Publicly Published: February 5, 2024
  • Researcher: Webbernaut
  • Description: The Elementor Addon Elements plugin is vulnerable to Stored Cross-Site Scripting (XSS) in versions up to 1.12.11. The vulnerability occurs due to insufficient sanitization of the 'link_to' parameter, allowing authenticated users with at least contributor privileges to inject harmful scripts into web pages, which are then executed when accessed by other users.


Elementor Addon Elements, a popular plugin designed to enhance the Elementor page builder with additional widgets and features, has been found to contain a significant security flaw in versions up to 1.12.11. This Stored Cross-Site Scripting vulnerability poses a risk as it enables attackers with contributor-level access to embed malicious scripts into web pages. The issue has been promptly addressed in version 1.12.12, where necessary security measures have been implemented to prevent such exploits.

Detailed Overview:

This vulnerability was identified by the security researcher Webbernaut, highlighting the critical need for stringent security practices in plugin development. The exploit takes advantage of inadequate input sanitization mechanisms within the plugin's 'link_to' parameter, underscoring the importance of validating and escaping user inputs to prevent malicious code injection. The potential for unauthorized script execution could lead to various security breaches, including data theft, site defacement, and compromised user accounts.

Advice for Users:

  • Immediate Action: Users of the Elementor Addon Elements plugin are strongly advised to update to the patched version 1.12.12 immediately to mitigate the vulnerability and secure their sites.
  • Check for Signs of Vulnerability: Site administrators should review their websites for any unusual or unauthorized content, particularly in areas where the affected parameter might be used, to identify potential exploitation.
  • Alternate Plugins: While the patched version addresses this specific vulnerability, users may consider evaluating other reputable plugins offering similar functionalities to diversify their security posture.
  • Stay Updated: Regularly updating all WordPress plugins, themes, and the core software is essential for maintaining site security. Users should monitor for and apply updates promptly to protect against known vulnerabilities.


The resolution of the Stored Cross-Site Scripting vulnerability in the Elementor Addon Elements plugin by the developers underscores the ongoing challenges faced in ensuring web security. The release of version 1.12.12 is a crucial step in safeguarding WordPress sites using this plugin from potential security threats. This incident serves as a valuable reminder of the importance of continuous vigilance, timely updates, and proactive security measures in the ever-evolving digital landscape.


In the digital ecosystem where websites serve as the cornerstone of businesses and personal platforms, the importance of cybersecurity is paramount. The recent discovery of the CVE-2024-0834 vulnerability within the "Elementor Addon Elements" plugin for WordPress brings to light the ongoing battle against security threats. This plugin, designed to extend the functionality of the Elementor page builder with additional widgets and features, is instrumental for over 100,000 websites, enhancing their user experience and interface. However, the identification of this Stored Cross-Site Scripting (XSS) vulnerability in versions up to 1.12.11 underscores the delicate balance between functionality and security.

Plugin Overview:

"Elementor Addon Elements," developed by webtechstreet, has been a popular choice among WordPress users, with more than 2.3 million downloads. It provides a range of custom widgets to augment the Elementor page builder, making website design more accessible and versatile.

Vulnerability Details:

CVE-2024-0834 exposes a security flaw where insufficient sanitization of the 'link_to' parameter allows authenticated users with at least contributor privileges to inject harmful scripts. This vulnerability, present in versions 1.12.11 and earlier, can lead to unauthorized script execution, posing significant risks to website integrity and user security.

Risks and Potential Impacts:

The exploitation of CVE-2024-0834 could result in data breaches, unauthorized access to sensitive information, and potential site defacement. The vulnerability primarily affects sites allowing user contributions, highlighting the need for stringent role management and input validation within WordPress environments.

Remediation Steps:

To mitigate this vulnerability, users must promptly update the plugin to the patched version 1.12.12. Additionally, website administrators should conduct thorough reviews for any unusual or unauthorized content and consider tightening user permissions to minimize potential exploitation vectors.

Previous Vulnerabilities:

This is not the first instance of security concerns associated with the "Elementor Addon Elements" plugin, with nine vulnerabilities reported since September 8, 2020. Each incident serves as a reminder of the evolving nature of web threats and the critical need for continuous monitoring and updating of all website components.


The swift resolution of CVE-2024-0834 by the plugin's developers highlights the ongoing challenges in maintaining web security and the crucial role of timely software updates. For small business owners managing WordPress sites, this incident underscores the importance of vigilance in updating plugins, themes, and core software. In an age where time is a scarce commodity, leveraging automated update features, subscribing to security advisories, and periodically consulting with cybersecurity professionals can provide a safety net, ensuring that your digital presence remains both robust and secure against the backdrop of an ever-evolving threat landscape.

Staying Secure

Staying on top of WordPress security can feel overwhelming for small business owners without dedicated IT staff. At Your WP Guy, we exist to shoulder that burden for you. Our WordPress experts can fully audit, secure, maintain and support your site - so you can focus on growing your business with peace of mind.

Don't tackle security risks alone. Let us help you assess any impact from this vulnerability, update your plugins, and implement ongoing maintenance to avoid future threats. We treat your website like it's our own - because we know how critical it is for reaching your customers.

Get in touch for a free consultation today on making WordPress security stress-free. Call 678-995-5169 or book a call here. Our knowledgeable team is ready to help you safeguard your online presence.

Elementor Addon Elements Vulnerability – Authenticated (Contributor+) Stored Cross-Site Scripting – CVE-2024-0834 |WordPress Plugin Vulnerability Report FAQs

Leave a Comment