Advanced iFrame Vulnerability- Authenticated Contributor+ Stored Cross-Site Scripting – CVE-2024-1341 | WordPress Plugin Vulnerability Report

Plugin Name: Advanced iFrame

Key Information:

  • Software Type: Plugin
  • Software Slug: advanced-iframe
  • Software Status: Active
  • Software Author: mdempfle
  • Software Downloads: 1,864,724
  • Active Installs: 60,000
  • Last Updated: February 28, 2024
  • Patched Versions: 2024.2
  • Affected Versions: <= 2024.1

Vulnerability Details:

  • Name: Advanced iFrame <= 2024.1
  • Title: Authenticated (Contributor+) Stored Cross-Site Scripting
  • Type: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:L/A:N
  • CVE: CVE-2024-1341
  • CVSS Score: 4.9
  • Publicly Published: February 28, 2024
  • Researcher: Fariq Fadillah Gusti Insani (fariqfgi)
  • Description: The Advanced iFrame plugin, a tool designed to embed content from other websites within an iFrame on WordPress sites, harbors a vulnerability in its shortcode implementation. Specifically, the plugin's allowance for the inclusion of external JS files via the additional_js attribute in all versions up to 2024.1 facilitates Stored Cross-Site Scripting (XSS) attacks. Authenticated users with at least contributor permissions can exploit this flaw to inject malicious scripts, which are then executed by any user visiting the compromised page.


The Advanced iFrame plugin for WordPress exhibits a security flaw in versions up to and including 2024.1, where its shortcode functionality can be misused for Stored XSS attacks by users with contributor-level access or higher. This vulnerability, now rectified in version 2024.2, posed significant security risks to WordPress sites using the plugin.

Detailed Overview:

This vulnerability, discovered by security researcher Fariq Fadillah Gusti Insani, underscores the importance of stringent input validation and output encoding in plugin development. By allowing external JS files to be included without adequate security checks, the plugin opened up avenues for attackers to embed harmful scripts into WordPress pages. The execution of these scripts compromises not only the security of the site but also the privacy and integrity of user data. The release of patch 2024.2 addresses this critical issue, reinforcing the plugin's defenses against such exploits.

Advice for Users:

  • Immediate Action: Users of the Advanced iFrame plugin should urgently update to the latest patched version, 2024.2, to mitigate the vulnerability and secure their sites.
  • Check for Signs of Vulnerability: Site administrators are advised to review their WordPress sites for any unusual or unauthorized content, which may indicate exploitation of this vulnerability.
  • Alternate Plugins: While the patched version is secure, users may consider evaluating alternative iframe plugins that consistently demonstrate strong security practices.
  • Stay Updated: Maintaining the latest versions of all WordPress plugins is crucial in safeguarding against known vulnerabilities. Regular updates ensure that security patches are applied promptly, reducing the window of opportunity for potential attacks.


The identification and swift patching of the Stored Cross-Site Scripting vulnerability in the Advanced iFrame plugin highlight the ongoing challenges and necessities in web security. This incident serves as a potent reminder to all WordPress users of the critical importance of regular software updates. By ensuring that plugins are kept up-to-date, users can significantly enhance the security posture of their WordPress installations, protecting against both current and future vulnerabilities.



In today's digital age, the security of online platforms is paramount for businesses of all sizes. The recent discovery of a vulnerability in the Advanced iFrame plugin for WordPress, identified as CVE-2024-1341, serves as a stark reminder of the ever-present threats in the digital landscape. This vulnerability highlights the critical need for constant vigilance and timely updates to ensure the safety and integrity of websites.

Advanced iFrame: A Key WordPress Plugin

The Advanced iFrame plugin is a widely used tool among WordPress users, enabling the integration of content from other websites within an iFrame. With over 1.8 million downloads and 60,000 active installations, its role in web development is significant. Developed by mdempfle, the plugin recently faced scrutiny when a security flaw was uncovered in versions up to 2024.1, prompting an immediate response from the development team.

The Vulnerability: CVE-2024-1341

CVE-2024-1341 is a Stored Cross-Site Scripting (XSS) vulnerability that arises from the plugin's shortcode functionality, specifically through the additional_js attribute, which allows for the inclusion of external JavaScript files. This flaw was identified by researcher Fariq Fadillah Gusti Insani, who noted that insufficient input sanitization and output escaping could enable authenticated users with contributor-level access or higher to inject malicious scripts. These scripts could then be executed by any user visiting the compromised page, posing a significant risk to site security and user data.

Risks and Potential Impacts

The implications of this vulnerability are far-reaching. Malicious script injection can lead to unauthorized access, data breaches, and a compromised user experience. For small business owners, the stakes are particularly high, as such security breaches can erode customer trust, lead to legal repercussions, and cause significant financial losses.

Remediation and Mitigation

In response to CVE-2024-1341, the development team released a patched version of the plugin, 2024.2, addressing the vulnerability. Users are urged to update their Advanced iFrame plugin immediately to this latest version to safeguard their sites. Additionally, site administrators should regularly review their sites for unusual or unauthorized content, which may indicate an exploitation of this vulnerability.

Historical Context

This is not the first challenge faced by the Advanced iFrame plugin; with 3 previous vulnerabilities reported since February 2, 2022, the plugin's security history underscores the ongoing battle against digital threats and the importance of continuous monitoring and updating.

The Importance of Proactive Security Measures

For small business owners, the task of staying on top of security updates amidst the myriad challenges of business operations can seem daunting. However, the discovery and patching of CVE-2024-1341 within the Advanced iFrame plugin underscore the critical importance of proactive security measures. Regular software updates, vigilant monitoring for security advisories, and a readiness to act swiftly in response to new vulnerabilities are essential practices to maintain the security and integrity of WordPress sites. In the rapidly evolving world of cyber threats, the commitment to securing digital assets is not just a technical necessity but a foundational aspect of building and sustaining trust with your audience.

Staying Secure

Staying on top of WordPress security can feel overwhelming for small business owners without dedicated IT staff. At Your WP Guy, we exist to shoulder that burden for you. Our WordPress experts can fully audit, secure, maintain and support your site - so you can focus on growing your business with peace of mind.

Don't tackle security risks alone. Let us help you assess any impact from this vulnerability, update your plugins, and implement ongoing maintenance to avoid future threats. We treat your website like it's our own - because we know how critical it is for reaching your customers.

Get in touch for a free consultation today on making WordPress security stress-free. Call 678-995-5169 or book a call here. Our knowledgeable team is ready to help you safeguard your online presence.

Advanced iFrame Vulnerability- Authenticated Contributor+ Stored Cross-Site Scripting – CVE-2024-1341 | WordPress Plugin Vulnerability Report FAQs

Leave a Comment