We update your WordPress Core on a regular basis to help ensure you don’t end up vulnerable to hacks based around your WordPress Core. A perfect example of why everyone on WordPress needs updates are the findings for WordPress 4.6.1 and 4.7.1 (also 5.0 & 5.0.1) that allowed WordPress Core to be compromised rather easily. At one point 30,000 websites had been hacked due to this one vulnerability alone.

Why is this important to you? Outside of securing your WordPress Core to prevent hacks. It also helps to prevent downtime. Some of these hacks took days to be found, as the sites weren’t monitored, and can sometimes take days to be fixed. How much does it cost your business when your website is down or if it were hacked?